Will all games have to be upgraded to (SDK)3.0 when it comes out?

Discussion in 'Off-Topic Lounge' started by florendas, May 2, 2009.

  1. florendas

    florendas Well-Known Member

    May 1, 2009
    146
    0
    0
    Does anyone know if all games will become 3.0 thus forcing all iPod Touch users to pay $10 to keep playing games?
     
  2. Boardumb

    Boardumb Administrator
    Staff Member Patreon Silver Patreon Gold

    Apr 14, 2009
    5,728
    244
    63
    THE BOSS
    Sacramento, CA
    I'm not sure, but I think it will depend on the game. I'm sure some will be 3.0 and up only, but I bet they still make games compatible with 2.0 and such. Would you really not want to get 3.0 though?
     
  3. 1337brian

    1337brian Well-Known Member

    Oct 12, 2008
    3,358
    3
    0
    In My Head
    I kind of have the same question, assuming a new Iphone/touch product launches this year with the 3.0 software, does that mean all the old apps we have will work on the new equipment? I would imagine it will, and if not a quick software patch should fix any compatibility issues, I was just wondering if anyone knows if this has been directly addressed already...
     
  4. Kamazar

    Kamazar Well-Known Member

    Dec 13, 2008
    6,509
    0
    0
    I'm pretty sure Apple's gonna do something about it. We're talking about millions of dollars and ten of thousands of devs.
     
  5. DaveMc99

    DaveMc99 Well-Known Member

    Mar 1, 2009
    4,761
    0
    0
    Seattle, WA USA
    All apps do not work with 3.0 beta.. why would you imagine they would? Urban Tycoon was supposed to get updated and did not.. the apps with active developers that care to update their app will make sure they work on 3.0.
     

Share This Page