Where to Download Beta Firmware

Discussion in 'Public Game Developers Forum' started by BulletDev, Oct 26, 2008.

  1. BulletDev

    BulletDev Well-Known Member

    Sep 20, 2008
    784
    0
    0
    produce applications under "Bullet Development"
    Vancouver, BC
    I am wondering where I can download a pre-release version of the iPhone OS that I can use for testing purposes. Whether it's a new version of 2.1 or 2.2 (which I've heard us developers can get) I will be glad for help.

    Thanks in advance!
     
  2. BulletDev

    BulletDev Well-Known Member

    Sep 20, 2008
    784
    0
    0
    produce applications under "Bullet Development"
    Vancouver, BC
    Anyone?

    Thanks again :)
     
  3. Frand

    Frand Well-Known Member

    If you're an official developer (paid the $99 fee), it's very easy to find. If you're not, then there's a reason you can't find it :)

    Developers sharing pre-release firmware with people outside their company would be in direct violation of their developer agreements.
     
  4. BulletDev

    BulletDev Well-Known Member

    Sep 20, 2008
    784
    0
    0
    produce applications under "Bullet Development"
    Vancouver, BC
    I am an official developer.

    I can't find it :confused:
     
  5. arn

    arn Administrator
    Staff Member

    Apr 19, 2008
    2,444
    19
    38
    My understanding is that the betas are only available to a subset of official iPhone developers.

    arn
     
  6. From my observation, it seems the betas are only available to the developers that where part of the original iPhone beta period. But a sample of one, is not much of a sample ;-)
     
  7. BulletDev

    BulletDev Well-Known Member

    Sep 20, 2008
    784
    0
    0
    produce applications under "Bullet Development"
    Vancouver, BC
    Really? That's too bad. In the Program Portal it did say that I could get it though.....

    But I think that I'll be trusting arn over whatever I'm thinking.
     
  8. CommanderData

    CommanderData Well-Known Member

    You must be one of the original 4000 accepted developers as far as I know. I was, and I do have access to each new beta as it comes out.

    Unless there's some specific feature of the new beta you absolutely must use in your app, you'll be much better off compiling for 2.0 compatible devices. That will give you the widest audience for your app. Some people will never upgrade their firmware :D
     

Share This Page