Update YouTube embed tag to support HTML5?

Discussion in 'Site Feedback and News' started by eisa01, May 30, 2011.

  1. eisa01

    eisa01 Member

    Jan 17, 2009
    9
    0
    1
    #1 eisa01, May 30, 2011
    Last edited: May 30, 2011
    I run Safari without Flash and I noticed that the YouTube videos you embed on the front page doesn't show up. AFAICT this is because you use the old embed code, if you switch to the new one, clients without Flash will get the HTML5 video player if it's available.

    Code:
    <iframe class="youtube-player" type="text/html" width="640" height="385" src="http://www.youtube.com/embed/VIDEO_ID" frameborder="0">
    </iframe>
    edit: You could probably change this for the forum embed code as well
     
  2. walker9

    walker9 Well-Known Member

    Aug 24, 2009
    58
    0
    0
    just testing to see if tihs works

    [​IMG]
     
  3. walker9

    walker9 Well-Known Member

    Aug 24, 2009
    58
    0
    0
    #3 walker9, Jun 8, 2011
    Last edited: Jun 8, 2011
    [​IMG]_
     
  4. walker9

    walker9 Well-Known Member

    Aug 24, 2009
    58
    0
    0
  5. eisa01

    eisa01 Member

    Jan 17, 2009
    9
    0
    1
    Just bumping this as it is still a problem, and it should be a simple fix :)
     
  6. Sanuku

    Sanuku Well-Known Member

    Could arn tell us if there is a Problem with that since i thought that it was already done month ago?
     
  7. eisa01

    eisa01 Member

    Jan 17, 2009
    9
    0
    1
    Nope, it works on iOS because there is some special code that manages YouTube embeds. If you don't have Flash installed on your Mac (no new Macs come with it preinstalled), you'll only get the "Missing plugin" error message.

    arn fixed this at MacRumors, so I'm sure it'll be an easy fix for him :)
     

    Attached Files:

  8. ultimo

    ultimo Well-Known Member

    May 5, 2009
    3,838
    0
    36
    Oi TA Admins, Please look into this, I second this!
     
  9. iJay

    iJay Well-Known Member

    Jan 11, 2011
    281
    0
    0
    Bump. It would be great if this could be fixed.
     
  10. j.dillinger

    j.dillinger Member

    Apr 15, 2012
    7
    0
    1
    Please, I second this. Registering on YouTube that you only want to view HTML5 doesn't work if your cookies are removed. I'm curious, why hasn't been implement thus far?
     
  11. gingerbeardman

    gingerbeardman Well-Known Member

    Aug 10, 2009
    104
    0
    16
    Male
    Former Apple Technology Evangelist
    #TeamGB
    Please fix this.
     
  12. MaliciousGod

    MaliciousGod New Member

    Sep 12, 2009
    1
    0
    0
    +1 here -- would love to see this fixed too.
     
  13. RoboWarrior

    RoboWarrior Well-Known Member

    Oct 3, 2012
    658
    0
    16
    This still hasn't been fixed, at least put in the url for the youtube link. It isn't exactly user friendly when one has to search for a trailer. I mean at least TheVerge and their crappy video player works without Adobe.
     
  14. Boardumb

    Boardumb Administrator
    Staff Member Patreon Silver Patreon Gold

    Apr 14, 2009
    6,542
    425
    83
    THE BOSS
    Sacramento, CA
    I don't understand what needs to be fixed. I don't have Flash installed and videos have always worked just fine for me. On my MacBook Air, on my iPhone, and on my iPad. All using the Safari browser. They all default to html5 versions automatically. Youtube made that mandatory for all their videos a long time ago. We use the standard Youtube tag on our Wordpress backend, and in the forums.

    There's really nothing weird going on here, yet every once in a while people complain that they can't watch Youtube videos and I just don't know what to tell them. Maybe you could give us what browser and operating system you're using?
     
  15. RoboWarrior

    RoboWarrior Well-Known Member

    Oct 3, 2012
    658
    0
    16
    I'm using a 2009 13" Macbook Pro using the latest Safari 8.0.6 and on OS X 10.10.3 so it's definitely not because my software isn't updated if that helps at all. The forums all default to html but the main site doesn't which is a bit odd for me.
     
  16. Eli

    Eli ᕕ┌◕ᗜ◕┐ᕗ
    Staff Member Patreon Silver Patreon Gold

    Updated.
     

Share This Page