STUCK on SUPERNOVA!! Please help

Discussion in 'General Game Discussion and Questions' started by MkktBkktsWeeWife, Sep 27, 2012.

  1. Hi there!
    Downloaded the Supernova add on for GOF2 HD on the iPhone 4S tonight ## but run into a bit of difficulty during the mission with Khador to fire a specially made missile into the Mido sun..
    This missile doesn't show up as being part of your ship's equipment before you embark on the mission and once you get close enough to the sun to fire there is no option in the secondary weapons for this isn't the primary weapon as you have just had a full blown firefight with stealth fighters using your normal guns..
    Am I missing something? (Dumb blonde female lol and I DID marry Mkkt Bkkt as you can see by my username so def possible lol ##)
    Any help appreciated, thanks in advance, Gillian xx
  2. Quantum Apocalypse

    Quantum Apocalypse Well-Known Member

    Mar 23, 2011
    Melbourne, Australia
    All you need to do is follow the waypoint and keep going towards the sun. The missile will fire automatically :)

    The Gamma Shield MKII is recommended to be used in the system generally :p
  3. STILL stuck but a little wiser! ##

    LoL thanks Apocalypse!#
    Just had to check - did seem one of those storyline type missions where it isn't left completely to the player; y'know the kind of GOF mission where the game does it for you making it idiotproof to ensure success for people like me..##
    So after realising I didn't have to install the weapon and checking it wasn't just a secondary weapon option I DID expect Khador to prompt me (or as you confirmed, the missile to fire automatically) when close enough to deploy..Khador does say its a one shot kinda deal as the parts are hard to find.. I have noticed that is usually a clue that you will get a bit of ingame help or prompting! BUT...
    I have now tried to complete the Mido sun mission six consecutive times with the same result: Gamma Radiation Shield activated, Khador and I set off, all is going to plan when the ??? pesky fighters appear to try and stop us..Engage fighters, keep flying to Waypoint with the distance counting down, the tenacious wee buggers just keep on coming - literally out of nowhere LoL! - til finally the countdown reaches zero.. It remains at zero for a long time, lol at least it seems a long time whilst still trying to fend those fighters off ### I wait for auto fire of missile/try looking for a way to manually deploy, my shield weakens and weakens until..#### KILLED AGAIN!!!
    At least now I know for sure It isnt me meant to be doing it manually and so.."If at first you don't succeed.." I shall just have to keep on trying!!## Thought occurs!#MAYBE keep flying past the zero point til I am closer still.. Yeah, think I'll give that a wee go see what happens!!
    Thanks again for your reply - really helps to know you are on the right track after all and haven't just missed something obvious or encountered a bug!! Been a great help mate, again much appreciate your help you are a #, an #, a gentleman and a scholar for aiding a damsel in distress so promptly!!
    Okay here goes.. Best get back to it; Carla will be in a tizzy over those curtains by now..##.. Oofft! Women eh? LMAO!!

Share This Page