iPad Do you use iPhone firmware 2.2? (Smiles)

Discussion in 'iPhone and iPad Games' started by PoV, Jan 5, 2009.

?

What firmware version do you run?

  1. Firmware 2.2 (latest)

    44 vote(s)
    97.8%
  2. Firmware 2.1

    0 vote(s)
    0.0%
  3. Firmware 2.0

    1 vote(s)
    2.2%
  1. PoV

    PoV Well-Known Member

    Oct 10, 2008
    349
    0
    0
    London, Ontario, Canada
    Hi there,

    I'm working on an update for my game Smiles (Smiles Zen, and Smiles Drop too), to address a sound issue among other things. I have a question for you guys and gals.

    Do you have iPhone/iPod Touch firmware 2.2 installed on your device?

    If you don't, iTunes usually complains whenever you sync. I know I've been running 2.0 and 2.1 on my devices (as a developer should), but I think developers are a special case.

    I mainly ask because 2.2 offers a pretty easy way to solve my sound bug, but I'm willing to do the complicated way if I find the majority hasn't moved over.

    Thanks,
    :D
     
  2. underthesun

    underthesun Well-Known Member

    Dec 23, 2008
    209
    0
    0
    As a developer, I'm also interested in this. I think you should put a poll in your post too.

    What happens when someone doesn't have 2.2 and tries to buy a 2.2 product?
     
  3. Mr. Charley

    Mr. Charley Well-Known Member

    Sep 6, 2008
    2,575
    2
    38
    I'm on 2.2.
    I think you're going to find 2 camps.

    Everyone who is not jailbroken will be on 2.2. There is absolutely no reason and no excuse to not be on 2.2 if you're not jailbroken

    Jailbroken, 1st gen Touches will be on 2.1.
     
  4. cptlockheed

    cptlockheed Well-Known Member

    Dec 12, 2008
    213
    0
    0
    IT professional since the 80's
    Finland
    Well, I was trying to not upgrade to 2.2 as it seemed buggy and more trouble than worth, but after the major music app (noise.io and beatmaker) updates started requiring it, I gave up and updated. I guess there is no holding back progress.

    I say go forth and use those 2.2 features for Smiles, that's why they were added I guess - to fix bugs and give better tools for developers.
     
  5. Ooo...shiny

    Ooo...shiny Well-Known Member

    Dec 2, 2008
    79
    0
    0
    Chemist
    Bay Area
    My first gen ipod touch is jailbroken and on 2.2.
     
  6. Carlos-Sz

    Carlos-Sz Well-Known Member

    Nov 5, 2008
    2,711
    0
    36
    Make a poll! :)

    Yes.
     
  7. PoV

    PoV Well-Known Member

    Oct 10, 2008
    349
    0
    0
    London, Ontario, Canada
    Good idea. :)

    With 2.0 and 2.1, purchases will work and download. But once they finish, the user gets a note that version isn't compatible with their device.
     
  8. Tharob

    Tharob Well-Known Member

    Dec 13, 2008
    220
    0
    0
    none
    Heerenveen, The Netherlands
    2.2 here
     
  9. Sambo110

    Sambo110 Well-Known Member

    Nov 27, 2008
    849
    0
    0
    Australia
    Uhh, what's wrong with a developer using 2.2? Isn't the latest version the best?
     
  10. underthesun

    underthesun Well-Known Member

    Dec 23, 2008
    209
    0
    0
    Oh, so it'll download, and then nag the user huh.. I was thinking for a while that iTunes will give you a warning or something along that line. Accidentally put space ninja on 2.2.

    Most probably, but for some apps it doesn't have any difference. Which is why for some it's probably better to stick to 2.0 and not alienate them instead.
     
  11. PoV

    PoV Well-Known Member

    Oct 10, 2008
    349
    0
    0
    London, Ontario, Canada
    Absolutely. For us developers, a new firmware usually gives us new things to play with. As of 2.1, I can check if you're playing your music when you start the game. 2.2 has that "System Sound Like" sound API, and an early look at that video out feature (not officially allowed yet, but it's there).

    But press is weird. A few ugly comments can actually discourage people from upgrading. Eventually a user will conform, but it might not be right away.

    Mind you, there's currently no way of knowing what the minimum Firmware requirement for an App is. Perhaps for the better?
     
  12. iPwnerNet

    iPwnerNet New Member

    Jan 5, 2009
    4
    0
    0
    I'm on firmware 2.2. There's no reason to be using an older firmware because the Safari browser in this firmware is very stable, apps install very fast, and backup syncings are fast as well.
     
  13. underthesun

    underthesun Well-Known Member

    Dec 23, 2008
    209
    0
    0
    Hmm.. are you sure? Apptism lists some apps as requiring 2.0 software update, while others as requiring 2.2 software update..

    I reckon hiding it away would probably be best for us developers though, maybe not for the users :p
     
  14. PoV

    PoV Well-Known Member

    Oct 10, 2008
    349
    0
    0
    London, Ontario, Canada
    You're right. I hadn't seen that yet. So obviously there's a way to know, just it isn't used by iTunes or the App Store.
     
  15. razorianfly

    razorianfly Well-Known Member

    100% agree. There is no excuse (apart from being a developer) for using a lower version of firmware.
    Also running 2.2. Anyone thinking 2.3/3.0 will arrive at Macworld? Hoping so. :cool:

    R-Fly
     
  16. Kursndax

    Kursndax Well-Known Member

    Oct 26, 2008
    106
    1
    0
    I am jailbroken since the 3G iphone came out and I recently upgraded cause lots of games coming out required 2.2 to play, it was a pretty easy 5 minute process, so I assume lots of people are on 2.2 by now. Jailbreaking is so easy now, a monkey could do it lol.
     
  17. superbad

    superbad Well-Known Member

    Nov 6, 2008
    2,117
    0
    0
    CEO. Reviewer. Beta Tester.
    You need to stalk me?
    what i think we need is for USERS to TYPE THEIR:

    - UNIT
    - Version #
    - JB / Non JB

    on their signatures

    i ALWAYS update to latest version
     
  18. Frand

    Frand Well-Known Member

    We've upgraded all our dev devices to 2.2 since 2.1 had broken OpenAL. Well, we did leave one device to 2.0 for compatibility checking, but all our game releases will require 2.2 (at least) from now on.
     
  19. fiskadoro

    fiskadoro Well-Known Member

    Jan 1, 2009
    301
    5
    18
    Chicago, IL
    Running 2.2 here. Personally looking forward to hearing the new update... Smiles is one of my favorite games, and it's great to see a developer here soliciting feedback from customers.
     

Share This Page