Universal Battle Chasers: Nightwar (by HandyGames)

Discussion in 'iPhone and iPad Games' started by metalcasket, Jul 31, 2019.

  1. RedHanded

    RedHanded Active Member

    Jul 16, 2015
    37
    0
    6
    Gotta start by stating just how much I enjoy this game! I really mean it! I own it on PS4 and barely ever touched it because of other games grabbing my attention and limited play time. Needless to say I jumped at the opportunity to play that on my iPad Air 2.

    Yeah...

    An older device like mine has had the toughest time running the game. Crashes galore (every 10 minutes or so), severe frame rate drops all the way to the dreaded single digits territory... Some dungeon tilesets displaying lots of lighting/weather effects have been an absolute nightmare! At some points, I came away feeling like I was fighting the actual game more than the enemies...

    Contacted the devs through their website. They suggested toning down the graphics. Tried 75% with no real improvements. Dipped all the way to 50% (what year is this?!? 2005?!?) and soldiered on. Nothing changed...

    Despite all the technical issues, I’m now a little over 60 hours played and completing the game’s seventh dungeon. If that’s not testament to just how fun the game is, I don’t know what is!!!

    Long story short, any gamer with a newer device owes it to himself to give the game a spin, plain and simple.

    Anyone rocking an older device should just wait for HandyGames to optimize the hell out of this thing before considering a purchase.
     
  2. squarezero

    squarezero Moderator
    Staff Member Patreon Silver

    Excellent — thanks!
     
  3. RedHanded

    RedHanded Active Member

    Jul 16, 2015
    37
    0
    6
    So about that Depleted Lightning Sigil you get in Caldeus’ Tomb...

    I’ve read online guides that mention you have to take it back to Deadwatch and “look for a sneaky set of stairs” (whatever that means!) that leads back outside to the surface and purposefully get hit by one of the random lightning traps.

    I’ve had my guys get hit by all manners of lightning traps in Deadwatch to no avail. Sigil is still resolutely depleted.

    Am I missing something? Can it only happen in a specific room I’ve never had in my runs so far?!?

    I’m reaching endgame and my completionist OCD is kicking in big time!

    Thanks for any help!
     
  4. RedHanded

    RedHanded Active Member

    Jul 16, 2015
    37
    0
    6
    Quick message to let you guys know HandyGames are deploying a patch today to hopefully stabilize the game on older devices!

    Fingers effing crossed, because the Crimson Gardens (Dungeon #7) has proven quite simply unplayable. Never made it past a third room without a hard crash even on 50% graphic settings...

    I’ve literally completed EVERYTHING ELSE that can be done content-wise (at this point, Garrison can two shot 12k health bosses with his ultimate weapon!) and now I’m just stuck on the Gardens.
     
  5. ioso

    ioso Well-Known Member

    Jul 6, 2017
    121
    27
    28
    Male
    Update is out but still no cloud sync
     
  6. Maillard55

    Maillard55 Member

    Jun 6, 2014
    14
    0
    1
    My iPad 6.0 was crashing in Junktown after the first battle before the update. Still crashing after, although a reduction in my graphics setting to 75% seems to be working. Fingers crossed that they optimize further with the RAM issue-- the graphics are outstanding in this and I hate to know that a new iPad can't run it at 100%.
     
  7. psj3809

    psj3809 Moderator

    Jan 13, 2011
    12,308
    347
    83
    England
    Finally bought this (didnt have the space previously). Wow ! Very impressive and so polished. Also bought it as i love the way Handy Games are updating Titan Quest as well

    Anyway looking forward to really getting into this game
     
  8. downgrad3r

    downgrad3r Well-Known Member

    Jul 1, 2016
    50
    41
    18
    I did the same. Expect to be rewarded handsomely. HandyGames are as courteous and engaged as any developers out there. User feedback is welcomed always—even encouraged!
     
  9. slrtrol

    slrtrol Member

    Apr 30, 2014
    6
    0
    1
    I updated today and got a debugging version. I'm pretty sure that it shouldn't have been released but the game still works. Funny enough I can avoid fights if I want with a debug auto kill.
     
  10. Yeah I got the debug thing as well... I don't know what happened when they updated the game and sent it to Apple. The text is just annoying me, I hope they fix it soon.
     
  11. solarnya

    solarnya Well-Known Member

    Jul 22, 2015
    621
    132
    43
    Male
    Close to Tokyo, Japan
    still waiting for cloud saving
     
    dlt0rre, Mycroft and skoptic like this.
  12. anthony78

    anthony78 Well-Known Member

    Nov 13, 2015
    2,540
    410
    83
    Not only is it in debug mode but it’s much glitchier too. Ramps that I can’t go up, forge that isn’t working, etc.

    Didn’t have any issues like this previously. Hope they patch it soon.
     
  13. andsoitgoes

    andsoitgoes Well-Known Member

    Not sure anyone cares but I got some clarification regarding controller support. Handy games was excellent at getting back to me. They spoke to the support team, and I’ll let them clarify:

    so alas it’s a no go for controllers it seems and there’s no plan to add it in. I’ve picked it up on the switch as with there being no cloud saves and an inability to copy the game saves (entirely possible this is an iOS 13 issue with iTunes on Windows not updating) I can’t even toggle between devices.

    i will say, though, man the game looks so much better on iOS. I never really put much into frame rate and such, but there’s a level of what I could best call “Vaseline” smoothing on the switch version that’s just... it’s hard to describe. But while it shines on my max and 2017 pro, it’s most certainly watered down on the switch. It does heat the heck out of my pro when playing it there, though, like close to dead cells level, but I presume ticking down the quality a hit would help a lot.

    hopefully I can actually justify putting the time in on the switch, it’s just such a perfect game to have with me on the bus
     
  14. Darkfyra

    Darkfyra Well-Known Member

    Jan 14, 2017
    157
    6
    18
    If it damage my iPad Pro, I would not buy it here but instead on PS4 or Switch, unless by heating up it mean charge drain fast.
     
  15. thor5678

    thor5678 Member

    Jun 1, 2016
    5
    1
    3
    #95 thor5678, Sep 21, 2019
    Last edited: Sep 21, 2019
    I’m having issues recently too. In the iron fort, I can’t get the sarcophagus to open. I went through the dialogue told it to do its worst then nothing. No more interact icon in the room. This happened the other day in the sewers. The blob lord appeared, he threatened me, then didn’t react. Couldn’t do anything to get him to react. I’ve already deleted and reinstalled the game. Anyone else having this issue? I have the 11” pro with latest software update.
     
  16. Talbs

    Talbs Well-Known Member

    May 1, 2011
    2,438
    265
    83
    On sale at the mo. Seems like about 30% off if anyone’s interested.
     
    ThirdMoon likes this.
  17. Darkfyra

    Darkfyra Well-Known Member

    Jan 14, 2017
    157
    6
    18
    Are the issues fixed?
     
  18. squarezero

    squarezero Moderator
    Staff Member Patreon Silver

    Last update was a week ago, so I would say yes. I never had any issues, though.
     
  19. imdakine1

    imdakine1 Well-Known Member

    Aug 23, 2011
    1,223
    21
    38
    Internet

    I read that this game need Internet access at all times? Not very airplane friends. Please advise if this is or not true.
     
  20. squarezero

    squarezero Moderator
    Staff Member Patreon Silver

    I just started it up in airplane mode without a hitch.
     

Share This Page