3.0 Has Broken My iPod!

Discussion in 'General Game Discussion and Questions' started by Sync, Jun 18, 2009.

  1. Sync

    Sync Member

    Apr 30, 2009
    21
    0
    0
    #1 Sync, Jun 18, 2009
    Last edited: Jun 18, 2009
    I bought and installed OS 3.0 on my 2G iPod Touch and now it's completely laggy. Opening apps and playing them is impossible, I tried to play Isotope and couldn't it was extremely laggy! I expected bugs, but this is not a bug, this has my iPod unusable!

    Did anyone else get this?

    Grammar Error: 3.0 Broke My iPod
     
  2. Stykman

    Stykman Well-Known Member

    Feb 6, 2009
    2,571
    0
    0
    Beta Tester, Student
    United States
    sucks for you some apps like isotope probably arent 3.0 tested

    there was an update submitted for that i think
     
  3. 1337brian

    1337brian Well-Known Member

    Oct 12, 2008
    3,358
    3
    0
    In My Head
    Try and restore it from a backup, it will keep the update, but maybe re-syncing to itunes will fix the issue?...;)
     
  4. pablo19

    pablo19 Well-Known Member

    Oct 26, 2008
    2,325
    2
    0
    It hasn't broken my ipod (since I can't sync), but I've paid TWICE for it, and my itunes doesn't work anymore, it also won't recognize my ipod when I connect them.
     
  5. mek

    mek Well-Known Member

    #5 mek, Jun 18, 2009
    Last edited: Jun 18, 2009
    a cold hard reset might help

    you may lose your data though

    first just try powering it off and restarting it, if that doesn't help

    hold down the power and home button to force it off....

    if that doesn't help, i can tell you the instructions to Cold hard reset it
    but if you have to do the last step, you will lose your data, just on your device
    and you will have to resync everything you want and redo all your settings

    it sucks, but at least your device isn't a brick paperweight

    here are the steps, for the iphone, and the ipod, to do a manual hard reset...use it as a last resort,

    1. Turn the iPhone ON
    2. CONNECT it to the dock
    3. Make sure iTunes is open so you'll know when it enters DFU mode
    4. HOLD the Power/Sleep-Wake button AND the Home button for 10 seconds
    5. RELEASE only the Power/Sleep-Wake button and continue to hold the Home button
    6. WAIT until iTunes recognizes the phone in DFU Restore mode (in Windows a bubble pops up saying it recognized new hardware "DFU Mode" or something to that effect)
    The last step may take SOME TIME, like, say, even 60 seconds or so. The screen should be OFF (black), if you see the "Connect to iTunes" logo, START OVER. It may take a few tries to do the steps just right, just reboot (hold both Power/Sleep-Wake AND Home until the Apple logo appears and the phone turns back on) then try again.
     
  6. BoiledGoose

    BoiledGoose Well-Known Member

    It's up to the developers to test for 3.0 and update if needed. The downside is that updates (and new apps) are taking extra long to get approved right now, so if something isn't working 100% correctly, it's possible the dev has already submitted an update and is waiting for it to go live. Hopefully this won't result is a bunch of unwarranted negative reviews in iTunes, but I can't see how it won't...
     
  7. eggzbacon

    eggzbacon Well-Known Member

    May 17, 2009
    5,808
    1
    0
    The Golden State
    Anyone else experience this problem?

    I downloaded 3.0 and when I open apps, they just quick out instantly
     
  8. mek

    mek Well-Known Member

    i had that problem with 2.0

    I remember having to reboot and resync my device a good 17 times until apple released a patch to fix it...it sucked
     
  9. randomdude

    randomdude Well-Known Member

    Mar 21, 2009
    1,657
    0
    0
    No problem...Just hold the quick home and power button for a reset
     
  10. eggzbacon

    eggzbacon Well-Known Member

    May 17, 2009
    5,808
    1
    0
    The Golden State
    ok i restored my iPod and everything is working fine.
     
  11. sundance kid

    sundance kid Well-Known Member

    Mar 15, 2009
    699
    0
    0
    eehhh
    BFE,AZ
    isotop is the only app i have had trouble with since i downloaded 3.0, besides cs. one but i think it was just laggy already and they have a update coming up to fix it. you'll just have to wait till all the apps are 3.0 compatible i guess, i dont know.its not the phone, its the games not being compatible with 3.0 i think
     
  12. quierrawinrow

    quierrawinrow New Member

    Jun 20, 2009
    1
    0
    0
    Same

    I'm having the EXACT same problem! and i paid for it twice too!
     
  13. yourofl10

    yourofl10 Well-Known Member

    Dec 11, 2008
    4,176
    1
    0

    The app probably wasnt built for OS 3.0. It's the devs problem. Just shoot them a e-mail.
     
  14. cloudlesssky22

    cloudlesssky22 Well-Known Member

    Apr 26, 2009
    78
    0
    0
    I updated my iPod Touch 2G to OS 3.0 and have no problems at all except for the YouTube app. Everytime I try to search or watch a video, the YouTube app keeps saying "Cannot Connect to YouTube." Don't know what I need to do to fix this???
     
  15. mattmanp

    mattmanp Well-Known Member

    Dec 8, 2008
    155
    0
    16
  16. elliott_2009

    elliott_2009 New Member

    Jun 20, 2009
    1
    0
    0
    I Hate It!!

    I Have A Origanal 2G Iphone And As Soon As I Installed The Software My Iphone Has Broken!! My Internet Has Stopped Woking, Games Dont Play And My Network Keeps Losing Connection!! Also My Messages Take Ages To Come Through!! Tryed Everything To Fix It But I Have Had No Luck!! Someone Help!!
     

Share This Page